0
Not a bug

Can't tick off subtask with new update

clausdh 6 years ago updated by Aymeric (Founder) 6 years ago 4
After the update this morning that also changed the layout to yellow colours - whenever I tick off a task with subtasks it ends the entire task instead of jumping to the next subtask as it did just yesterday. This is really annoying because I used the subtasks feature extensively - please bring it back - I really like WeekPlan to schedule my tasks!
App:
Under review
Claus, is the issue solved for you?
Nope - but maybe its not supposed to be solved? When I click on the a task with subtasks it used to indicate that the current subtask was done and then display the next subtask - this is not happening now - but maybe that is intentionally? Instead when clicking the task (with subtasks) it indicates that the entire task is done. I can click edit and go into the task and then click off the subtask there - that works fine - but I liked the way it worked 1½ weeks ago better. 
Hi Claus, I found that people were getting confused with the way subtasks were working before. For example, they wouldn't understand that it would be the underlying next subtask that would be marked as completed, or whether it would be the parent task itself. Also, the way the subtasks were shown in the Week view, it was overtaking the important of the parent task.

So I decided to make it a bit more conventional by making users tick subtasks from within the Edit dialog.

Thanks for your feedback though, it is important to hear what people think of the changes I make.