Cannot enter text into outline

BM Brooks 5 years ago updated by Aymeric (Founder) 2 years ago 7
Tried both in Firefox (whatsmybrowser.org/b/4GPUTEX) and Internet Explorer (whatsmybrowser.org/b/GTPY8O3)

First attempt at using the outlining feature. Cannot enter any text (bang keys, nothing happens). A few times I was able to get text into outline by copying/pasting from notepad into the web form, other times the paste didn't do anything. When I have been able to paste some text into the outline, I can type text from keyboard into the web form, however after 1 or 2 characters I receive a dialog box popup announcing a Server Error with the close/reload button combo.

I have tried closing the weekplan tab in the browsers, completely exiting browsers, trying alternative browsers, all with the same result
Under review
I am not able to reproduce this issue. Do you still experience it?
I am currently having this issue. I was exited to use it and while testing it I was able to enter text, but as soon as I tried to do it for real I can not edit the nods or enter any information.
Under review
What internet browser are you using? We will do some more testing.
I did post the browser versions in the original comment.

Out of the approximately 10 times I have gone into the outliner, 6 of the times I have experienced the problem. I have been trying to track when it occurs versus when I can get into the service. So far I haven't noticed a pattern, but I am continuing to check.

An additional clue (maybe) when I am able to get in I have added text into the outline, when I cannot type anything into the outliner, my prior outline is not visible.

I am guessing that the outliner is using a web 2.0/ajax kind of technology to communicate between front-end and back-end. Is it possible the communication is being blocked by some itermediate firewall?

A little more investigating, not much progress.

I tried Firefox in safe mode, outliner was inactive.
I tried clearing offline storage, thinking maybe something was corrupted in local storage, no change.
I tried chrome (I can generate version info if it would help).

The strange part is I cannot even put a cursor into the content box between 'Organize your brain' and 'Enter'.
I then tried using the inspector feature of Firefox to look at the content box. The resulting HTML is below. While I am a novice with HTML it is surprising that the majority of the "code" is commented out

<div class="content-box outliner">
<!-- ko component: {
name: "action-buttons",
params: { type: 'outliner' } } -->
<!-- ko if: selectedAction() && selectedAction().ActionId() -->
<!-- /ko -->
<!-- /ko -->

<!-- ko component: { name: "node-buttons" } -->
<!-- ko if: selectedNode() && selectedNode().NodeId() -->
<!-- /ko -->
<!-- /ko -->

<ol data-bind="
template: {
name: 'nodeTemplate',
foreach: Root.Nodes }"></ol>