0
Fixed

Paid for a year - cannot use pro features

sturmwarnung 4 years ago updated by Aymeric (Founder) 4 years ago 13
I sent this 3 weeks ago as email, never got an answer. I paid for the pro version for one year, but cannot use most of the pro features.
Problem #1 - Zapier integration:
Cannot connect weekplan as a service. When I try and enter the api key provided in weekplan settings, I get an error message (invalid API Login).
Problem #2 - Google Calendar:
Syncs when first connected, but never syncs after that. I need to disconnect and reconnect the calendar to trigger a sync.
Problem #3 - Google Calendar
Not sure if connected to #2, but showing events on Google calendar shows multiple instances of recurring tasks. Those tasks have not been postponed or ignored, they just keep piling up in GC.
I suspect the problem could be that I signed up with a google account, not through email/password registration. If that's the case, I could register a new account and you could transfer my existing paid subscription to the new one.
If we cannot find a solution, I would like my money back.
App:
Under review
Problem #1:

I have tested again just now and Zapier seems to be working.

Please make sure you get all the characters from the API key field, the content is longer than the field's width:
https://gyazo.com/03c8515689dc558dd6043c5d529c3131

And this is how it looks like in Zapier: https://gyazo.com/0a4f795675e104107f4f78a1397aec73
I tried it again, it doesn't work for me. Key has the right format (36 digits/letters with the dashes in the same place as in your example), still get the same error message.
I found that your account had been deactivated. Did you ever manually deactivate your account?
Hm, it could be. When I signed up/in, I found some entries already there, which means I must have tried weekplan at some time in the past. Maybe I deactivated it back then? But then there shoudldn't have been anything left, I think?
So, any way to correct this situation?
Problem #2:

I looked at this issue and found that your account wasn't getting picked up by the recurring sync task. This should be fixed now.
When I opened weekplan in the morning, events I created yesterday were not displayed, so I disconnected and reconnected again. Will see if it works automatically from now on.
Problem #3:

Could you please give me the exact text of a recent task that keeps piling up?
I deleted them because they took up all space in month view, but with the disconnecting/reconnecting it started again. (Screenshot) I guess this problem will correct itself when sync works by itself.
Zapier works now as expected, sync is also working, Thank you!
Fixed
Excellent! I am just wondering about the duplicates you have seen, the developer had a deep look into the logs but couldn't find a good explanation. Hopefully the issue is resolved too.
Having the same problem as well!

What problem do you have exactly?