Under review

calendar not syncing

calvinwilliamsjr 4 months ago updated by Dev team 4 months ago 27

google is not syncing

Web app

Mine isn't syncing either. What was the 'user error'?

Perhaps I've made the same one.

Under review

We are sorry for the inconvenience. Our devs are looking into it and we will get back with an update soon. 

Thank you for understanding.

I'm dead in the water .... any updates?



we are truly sorry for the long wait. We will try to deploy the fixes today. 

Your patience will be highly appreciated.

Thanks & Regards,



We deployed Sync fixes. Could you please confirm if it is working for you now?

Thank you so much for your patience. 

I'm afraid it doesn't appear to be working. I have checked my calendar on my phone (iOS) which is synced to my Gmail calendar, and nothing is coming up there. I have also checked on the online Gmail web app and nothing is coming up from Weekplan on my calendar there either. I have saved the settings for push and pull, and clicked tigger sync, but I'm not getting anything yet.

Hi Andy,

I noticed you haven't enabled push and pull settings for your calendar. Could you enable pull/push for the calendar you want to sync and check if it works for you? 

You can refer to this article on how to enable push/pull settings for calendars: 




Seems to be working - I had to turn off and turn on again to get it to sync.



We have introduced some fixes recently so it should improve calendar sync expierence

I logged in and clicked the buttons, then clicked  trigger sync, and save.

I then logged out and then back in again and ... 

What’s more, even though I have clicked trigger sync, there is still no syncing with the calendar. Perhap Dev needs another look 👨🏻‍💻👨🏻‍🔧

Thank you for confirming us. I noticed push is enabled for your calendar and the screenshot is shared of the mobile app. Could you please confirm it is an android or iOS app? Also could you please refresh the app from the refresh button in the profile menu. 

It’s happening whether I use the iOS app, or on my mac desktop. I have just this minute checked it with my windows desktop and it happens on there too. 


Could you please enable push and/or pull and click "save" button first before clicking "Trigger synchronisation" button as we are unable to replicate this issue. If it doesn't helped could you please share a video screenshot or the steps?

Do you want push/pull on for the first calendar?

How do I do videos? Thanks (MacOs)
Here you go.

I've had to save the screen capture as a low quality video or the file would have been too large to send.

I have also tried to do this with using the refresh button after saving in the push/pull page, and that doesn't work either.


weekplan sync low qual.mov

Thank you for the details and we are sorry for the inconvenience. Our devs are looking into it will soon get back to you with the fixes.

Your patience will be highly appreciated.


No problem. Weekplan is a great product and has huge potential. I’m willing to wait. 

My calendar is not synced as well. I had setup push and pull calendar from my email already. Can you please check and get back to me?


Is pull or push not working for your account?


Yes - we have fixed saving calendar settings. Currently you have Google Sync disabled:

You can enable it by clicking push/pull and click Save.

It doesn't appear to have resolved the issue. Check this video out.

Thanks for the details - we will check that and fix as soon as possible.

Hi, we have just released new fixes - your settings should be preserved right now. Many thanks for your video.

Kind regards